metamorfoza

модели персонажей состоят из трех частей: голова, торс и ноги. это позволяет использовать большое количество доспехов сразу для всех персонажей. В местах соединений модели состыкованы. для всей модели используется один анимационный скелет, а части модели меняются. если голова остается постоянной, то вот все остальные части меняются в зависимости от того, какое облачение выберет игрок. предполагается около десятка голов, различающихся комплекцией и некоторыми особенностями. например предполагается сделать отдельный вид головы для существ с вытянутыми заостренными ушами, а также несколько звериных голов для зверо-людей. большое количество текстур, накладывающихся на одни и теже модели в сочетании с несколькими различными по геометрии моделями создадут достаточно большое количество вариантов персонажей. Что касается моделей амуниции, то их будет достаточно большое количество. они будут едиными для всех персонажей. цвет кожи, татуировки и другие отличительные особенности персонажей предполагается менять при помощи текстур. для всех персонажей будут использоваться одни и те же анимационные скелеты. количество анимаций будет достаточно большое. примерно по три варианта каждого движения. это создаст впечатление различий в движениях разных персонажей.

для того, чтобы реализовать все вышеописанное, удобнее всего воспользоваться одной первоначальной моделью и потом ее модифицировать. первоначально необходимо создать персонаж без одежды, доспехов и т. д. однако следует уже на этапе разработки предусмотреть то, что предполагается изменение модели. отдельные части тела должны легко модифицироваться в различную одежду\амуницию при незначительном добавлении деталей. на моделе необходимо создать вертексные пояса в местах ее разделения (на поясе и на шее). в дальнейшем необходимо будет удалять нижнюю, либо верхнюю часть модели для экспорта в отдельную деталь снаряжения. геометрию этих поясов необходимо сразу продумать, так как потом она меняться практически не будет. это необходимо для стыковки отдельных частей амуниции между собой. модель должна быть изначально цельная, в ней не должно быть отдельных деталей. полигональность модели - средняя. при выборе количества полигонов нужно учитывать следующее: модель должна быть качественная; камера располагается на некотором расстоянии, но ее можно приближать, поэтому какими-то деталями можно принебречь, но явных огрехов не должно быть заметно; в игре предполагается большое количество персонажей, поэтому слишком высокополигональные модели будут перегружать память; модель будет анимироваться, поэтому вершины должны быть удобно для этого расположены, например, на стыках частей, суставах, и т. д. нужно предусмотреть вертексные пояса для последующей качественной костной анимации; модель предполагается многократно модифицировать, видимо повертексно, поэтому вершины должны хорошо выделяться и быть легкодоступными для перемещения, поворота, и т. д. необходимы две модели персонажей: мужская и женская.